Opened 3 months ago

Closed 3 months ago

#13846 closed bug (duplicate)

GHC Panic: Visible type application + function type @(_ -> _)

Reported by: Iceland_jack Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.3
Keywords: TypeApplications Cc: goldfire
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #13819 Differential Rev(s):
Wiki Page:

Description

$ ghci -XTypeApplications -ignore-dot-ghci
GHCi, version 8.3.20170605: http://www.haskell.org/ghc/  :? for help
Prelude> :t fmap @(_ -> _)
ghc: panic! (the 'impossible' happened)
  (GHC version 8.3.20170605 for x86_64-unknown-linux):
	repSplitAppTys
  w0_a1pF[tau:2]
  w0_a1pH[tau:2]
  []
  Call stack:
      CallStack (from HasCallStack):
        prettyCurrentCallStack, called at compiler/utils/Outputable.hs:1133:58 in ghc:Outputable
        callStackDoc, called at compiler/utils/Outputable.hs:1137:37 in ghc:Outputable
        pprPanic, called at compiler/types/Type.hs:809:9 in ghc:Type

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Prelude> 

Doesn't happen with other types it seems, probably something to do with levity polymorphism.

Change History (2)

comment:1 Changed 3 months ago by simonpj

Cc: goldfire added

I'm betting this is a dup of #13819.

comment:2 Changed 3 months ago by RyanGlScott

Resolution: duplicate
Status: newclosed

Yes, this is absolutely a duplicate of #13819, as this bug surfaced in the same commit (b207b536ded40156f9adb168565ca78e1eef2c74). To consolidate, I'll close this one in favor of #13819.

Note: See TracTickets for help on using tickets.