Opened 7 weeks ago

Closed 7 weeks ago

#13672 closed feature request (duplicate)

Pattern match on LHS of pattern synonym declaration

Reported by: Iceland_jack Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.0.1
Keywords: PatternSynonyms Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #12203 Differential Rev(s):
Wiki Page:

Description

Changing ZipList to a newtype

import Data.Bifunctor.Fix
import Data.Bifunctor.Tannen

type ZipList = Fix (Tannen Maybe (,))

pattern Nil :: ZipList a
pattern Nil = In (Tannen Nothing)

infixr 5 :::
pattern (:::) :: a -> ZipList a -> ZipList a
pattern a:::as = In (Tannen (Just (as, a)))

works fine for the Nil pattern synonym (it remains implicitly bidirectional)

newtype ZipList a = ZL (Fix (Tannen Maybe (,)) a)

pattern Nil :: ZipList a
pattern Nil = ZL (In (Tannen Nothing))

but (:::) needs to be explicitly bidirectional

infixr 5 :::
pattern (:::) :: a -> ZipList a -> ZipList a
pattern a:::as   <- ZL (In (Tannen (Just (ZL -> as, a))))
  where a:::ZL as = ZL (In (Tannen (Just (as, a))))

I would like to write it as

pattern (:::) :: a -> ZipList a -> ZipList a
pattern a:::ZL as = ZL (In (Tannen (Just (as, a))))

Change History (1)

comment:1 Changed 7 weeks ago by RyanGlScott

Resolution: duplicate
Status: newclosed

I'm closing this as a duplicate of #12203, since that ticket asks for the same thing (albeit with a different motivating example). I'll add this example to #12203 for posterity's sake.

Note: See TracTickets for help on using tickets.