Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#1358 closed bug (invalid)

debian package ghc6-doc should depend on haddock?

Reported by: Frederik Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.6.1
Keywords: Cc: Ian Lynagh (wibble) <igloo@…>
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

$ sudo apt-get install ghc6-doc Reading package lists... Done Building dependency tree... Done ghc6-doc is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded. 1 not fully installed or removed. Need to get 0B of archives. After unpacking 0B of additional disk space will be used. Setting up ghc6-doc (6.6.1-1) ... /usr/lib/ghc6-doc/gen_contents_index: line 34: haddock: command not found dpkg: error processing ghc6-doc (--configure):

subprocess post-installation script returned error exit status 127

Errors were encountered while processing:

ghc6-doc

E: Sub-process /usr/bin/dpkg returned an error code (1)

Change History (4)

comment:1 Changed 10 years ago by ross

Resolution: invalid
Status: newclosed

this belongs in the Debian BTS

comment:2 Changed 10 years ago by Frederik

Cc: Ian Lynagh (wibble) <igloo@…> added

Sorry, for some reason I had the impression that the Debian maintainer read this bug database and perhaps other distribution maintainers might want to check that they don't make the same error. However, in the future, I will try to do as you request.

comment:3 Changed 8 years ago by simonmar

Architecture: UnknownUnknown/Multiple

comment:4 Changed 8 years ago by simonmar

Operating System: UnknownUnknown/Multiple
Note: See TracTickets for help on using tickets.