Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1327 closed bug (duplicate)

internal error: interpretBCO: unknown or unimplemented opcode 35464

Reported by: gleb.alexeev@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.6
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Steps to reproduce:

  1. Load the following module into ghci:
module Bug where

import Test.QuickCheck

data Color = Red | Yellow | Blue deriving (Eq, Show)

complement :: Color -> Color -> Color
complement c1 c2 = f (c1,c2)
    where f (Red, Yellow)  = Blue
          f (Red, Blue)    = Yellow
          f (Yellow, Blue) = Red
          f (x,y) = f (y,x)

prop_complement c1 c2 = c1/=c2 ==> c3/=c1 && c3/=c2 where c3=complement c1 c2

instance Arbitrary Color where
    arbitrary = oneof $ map return [Red, Yellow, Blue]
    coarbitrary = undefined

  1. Evaluate 'quickCheck prop_complement'

ghci crashes with the following output:

*Bug> quickCheck prop_complement
Loading package QuickCheck-1.0 ... linking ... done.
<interactive>: internal error: interpretBCO: unknown or unimplemented opcode 35464
    (GHC version 6.6 for i386_unknown_mingw32)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

The problem disappears if complement function is invoked manually before calling quickCheck.

Change History (3)

comment:1 Changed 7 years ago by thorkilnaur

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks a lot for this report. It seems that this is a duplicate of #1013, so I will take the liberty of closing this ticket. For additional details, see http://www.haskell.org/pipermail/glasgow-haskell-bugs/2007-March/008800.html: The error is present in GHC 6.6, but should be fixed in GHC 6.6.1.

Best regards
Thorkil

comment:2 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:3 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.