Opened 9 years ago

Closed 9 years ago

#1320 closed task (duplicate)

FAQ item for running GHCi on WinXP x64 using DEP

Reported by: guest Owned by:
Priority: low Milestone:
Component: GHCi Version: 6.6.1
Keywords: DEP, XP, x64, amd64, windows Cc:
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:



I don't know if this is a bug or not, but here is what I have witnessed:

In order to get ghci to run on Windows XP x64, I needed to add ghci.exe to the "data execution prevention" exception list. Before making this exception, running ghci.exe would pop open my debugger with an access violation.

Data Execution Prevention restricts the OS from executing any code that has been marked in memory as 'data'. I presume that the interpreter is taking in some strings, doing some processing on that data; then treating it as executable code and trying to run it. That sounds like a reasonable thing to do, and I don't know if there is a way to prevent it from triggering DEP.

If this isn't a bug, perhaps you will consider this exception as a FAQ entry.

-- Chris Messer (c.s.messer@…)

Change History (1)

comment:1 Changed 9 years ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed

I'm assuming this is a duplicate of #885, which is fixed in 6.6.1. I'm also guessing that you marked the bug as 6.6.1 because that's the default, not that it actually happens on 6.6.1. If this is wrong and you still see the bug with 6.6.1, please re-open this ticket.

Note: See TracTickets for help on using tickets.