Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1299 closed feature request (wontfix)

"sh boot" should give a better error message if automake isn't installed

Reported by: chevalier@… Owned by:
Priority: normal Milestone:
Component: Build System Version: 6.6.1
Keywords: Cc:
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I was building GHC from scratch on a new machine that didn't have automake installed, and sh boot gave the following error message:
Can't exec "aclocal": No such file or directory at /usr/bin/autoreconf line 182.
Use of uninitialized value in pattern match (m) at /usr/bin/autoreconf line 18 2.
Can't exec "automake": No such file or directory at /usr/bin/autoreconf line 183 .
Use of uninitialized value in pattern match (m
) at /usr/bin/autoreconf line 18 3.
(repeated five times)

It would be nice if the script checked whether automake was installed. Or, at least, maybe if the first attempt to use automake failed, there might be a way to avoid printing out the same error message five times; it's a little forbidding. (I'm sure the documentation says you need automake, but it might be nice to have a better error message even so.)

Change History (3)

comment:1 Changed 7 years ago by igloo

Hrm, the reason you get the messages 5 times is that autoreconf doesn't fail as a result of them, so we don't know anything has gone wrong and keep going. As we autoreconf in ghc and libraries/{base,Win32,readline,unix} the messages are given 5 times. I'm not sure what we can do about that.

As for detecting automake, the problem is that we don't call it directly ourselves, so we don't know where it is (particularly when autoreconf isn't installed in the standard location).

Has anyone got any suggestions, or should I just close the bug?

comment:2 Changed 7 years ago by igloo

  • Resolution set to wontfix
  • Status changed from new to closed

Closing the bug as wontfix (although "cantfix" would be more accurate). Please reopen if you have a better idea.

comment:3 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.