Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1296 closed bug (fixed)

-fwarn-monomorphism-restriction breaks package compilation

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.7
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Just try to compile regexp-compat.

Change History (3)

comment:1 Changed 7 years ago by simonmar

  • Resolution set to fixed
  • Status changed from new to closed

regex-compat fixed. If you use -Wall -Werror, then you are vulnerable to new warnings being added, I think that's unavoidable. It would be safer to explicitly list the warnings you want turned on when using -Werror.

comment:2 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:3 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.