#12481 closed feature request (duplicate)

Add MonadFail instance for Either String

Reported by: hesiod Owned by:
Priority: normal Milestone:
Component: Core Libraries Version:
Keywords: Cc: ekmett
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

There seems to be the low hanging fruit of a MonadFail instance for Either String.

instance MonadFail (Either String) where
    fail = Left

Change History (2)

comment:1 Changed 16 months ago by hesiod

I just realized that this instance has already been mentioned in https://prime.haskell.org/wiki/Libraries/Proposals/MonadFail, not in base however, but rather in transformers. I'm not quite sure why having that instance in transformers would be better, since it would make it an orphan.

comment:2 Changed 16 months ago by hesiod

Resolution: duplicate
Status: newclosed

Nevermind, this is a duplicate of #12160.

Note: See TracTickets for help on using tickets.