Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1237 closed bug (invalid)

misleading error message from cabal when versions differ

Reported by: guest Owned by:
Priority: normal Milestone:
Component: None Version: 6.7
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Using cabal, I do './Setup.hs configure', './Setup.hs build', and 'sudo ./Setup.hs install'. Unfortunately, root's $PATH pointed to a different GHC (6.7 at some point, and not 6.4.2 which I was using), which resulted in the error message:

Setup.hs: error reading ./.setup-config; run "setup configure" command?

Of course, there was nothing wrong with .setup-config, so I spent some time investigating permissions, before int-e suggested that the search path was at fault.

Change History (3)

comment:1 Changed 7 years ago by igloo

  • Resolution set to invalid
  • Status changed from new to closed

I've opened a bug for this on the Cabal trac:
http://hackage.haskell.org/trac/hackage/ticket/120

comment:2 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:3 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.