Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#12148 closed bug (worksforme)

GHC 8 crash when building "chatter" library

Reported by: varosi Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.0.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #10852 Differential Rev(s):
Wiki Page:

Description

While I try to build "chatter" library from GitHub with Stack with GHC 8.0 resolver I got that crash:

[ 9 of 23] Compiling NLP.Corpora.Brown ( src\NLP\Corpora\Brown.hs, .stack-work\dist\b7fec021\build\NLP\Corpora\Brown.o ) ghc.exe: panic! (the 'impossible' happened)

(GHC version 8.0.1 for x86_64-unknown-mingw32):

Simplifier ticks exhausted

When trying RuleFired Class op unsafeShiftR To increase the limit, use -fsimpl-tick-factor=N (default 100) If you need to do this, let GHC HQ know, and what factor you needed To see detailed counts use -ddump-simpl-stats Total ticks: 11403800

Attachments (2)

stack.yaml (1023 bytes) - added by varosi 19 months ago.
Modified file from master branch
InstanceSerialize.hs (4.3 KB) - added by thomie 19 months ago.

Download all attachments as: .zip

Change History (8)

Changed 19 months ago by varosi

Attachment: stack.yaml added

Modified file from master branch

comment:1 Changed 19 months ago by varosi

With -fsimpl-tick-factor=200 it worked just fine. I don't know if it should be considered bug?

Changed 19 months ago by thomie

Attachment: InstanceSerialize.hs added

comment:2 Changed 19 months ago by thomie

Thanks for reporting.

Can you try upgrading cereal to version 0.5.2? I think that fixes it.

comment:3 Changed 19 months ago by thomie

Architecture: x86_64 (amd64)Unknown/Multiple
Operating System: WindowsUnknown/Multiple

comment:4 Changed 19 months ago by varosi

It is working fine with 0.5.2 without need of that option.

comment:5 Changed 19 months ago by thomie

Resolution: worksforme
Status: newclosed

It works for me as well, using GHC 8.0.1 and http://www.stackage.org/snapshot/nightly-2016-06-02, which contains cereal 0.5.2.0.

This seems to have fixed it, from the cereal 0.5.2.0 release notes:

Split the GSerialize class in two, to deal with a GHC bug (thanks Austin Seipp!)

The GHC bug they refer to is #5642, and it is still open.

Thanks again for reporting.

comment:6 Changed 19 months ago by varosi

Thank you, too!

Note: See TracTickets for help on using tickets.