Opened 7 years ago

Closed 6 years ago

#1208 closed bug (duplicate)

ghci-6.6 aborts at initialization

Reported by: dfeustel@… Owned by:
Priority: normal Milestone: 6.8 branch
Component: GHCi Version: 6.6
Keywords: Cc: dons@…
Operating System: OpenBSD Architecture: x86_64 (amd64)
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

A40:/home/daf}ghci
   ___         ___ _
  / _ \ /\  /\/ __(_)
 / /_\// /_/ / /  | |      GHC Interactive, version 6.6, for Haskell 98.
/ /_\\/ __  / /___| |      http://www.haskell.org/ghc/
\____/\/ /_/\____/|_|      Type :? for help.

2/ghc-6.6: /usr/local/lib/ghc-6.6/HSbase.o: unknown architecture
Loading package base ... ghc-6.6: panic! (the 'impossible' happened)
  (GHC version 6.6 for x86_64-unknown-openbsd):
        loadObj: failed

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (3)

comment:1 Changed 7 years ago by igloo

  • Description modified (diff)
  • Milestone set to 6.8

Currently ghci has some stuff that needs to be ported for each OS/architecture. I do have some patches to make it work anywhere, I just need to tidy them up and commit them.

comment:2 Changed 6 years ago by simonmar

  • Cc Don Stewart <dons@…> added

Don: this looks like a duplicate of #1225, do you agree?

comment:3 Changed 6 years ago by igloo

  • Cc dons@… added; Don Stewart <dons@…> removed
  • Resolution set to duplicate
  • Status changed from new to closed

This looks like a duplicate of #1225; please reopen if I'm wrong.

Note: See TracTickets for help on using tickets.