Opened 7 years ago

Closed 7 years ago

#1180 closed bug (invalid)

ghci 6.7 PPC memory corruption

Reported by: allbery@… Owned by:
Priority: normal Milestone:
Component: GHCi Version: 6.7
Keywords: Cc:
Operating System: MacOS X Architecture: powerpc
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

{{{mress:5017 Z$ compiler/stage2/ghc-inplace --interactive

_ _ _

/ _ \ /\ /\/ (_)

/ /_\ /_/ / / | | GHC Interactive, version 6.7.20070224, for Haskell 98.

/ /_
/ / /_| | http://www.haskell.org/ghc/
\/\/ /_/\/|_| Type :? for help.

ghc-6.7.20070224(25701,0xa000ed88) malloc: * error for object 0x3807ff8: pointer being reallocated was not allocated
ghc-6.7.20070224(25701,0xa000ed88) malloc:
* set a breakpoint in szone_error to debug
malloc: failed on request for 10331948 bytes; message: ocAllocateJumpIslands}}}

Interestingly, when I invoke it through gdb the breakpoint in szone_error is ineffective (although gdb has in the past had enough bugs in its breakpoint support that I wonder if it's gdb that's broken here and not some strange confusion in what malloc library is being invoked or etc.)

I've placed the build log (including testsuite output) from this build at http://www.ece.cmu.edu/~allbery/ghc67-20070218.log in case there's something obvious there about something I'm doing wrong.

Change History (1)

comment:1 Changed 7 years ago by thorkilnaur

  • Resolution set to invalid
  • Status changed from new to closed

Thanks a lot for this report. This seems to be caused by the patch merge error for which a patch was applied on 2007-Jan-28. See http://www.haskell.org/pipermail/glasgow-haskell-users/2007-January/011920.html. I can find the patch applied to a recently pulled ghc HEAD:

Sun Jan 28 22:32:16 CET 2007  Ian Lynagh <igloo@earth.li>
  * Fix GHCi on PowerPC OS X
  David Kirkman and Peter Tanski noticed that a line had been removed during
  a patch merge which meant that oc->image pointed to the wrong place and
  ultimately caused an error from realloc.

So I am closing this bug report. Please feel free to reopen if you cannot make this problem go away.

Note: See TracTickets for help on using tickets.