Opened 7 years ago

Closed 7 years ago

#1178 closed bug (duplicate)

ghci 6.6 dies on nobench 'chess' program with unknown opcode error

Reported by: dons Owned by:
Priority: normal Milestone:
Component: GHCi Version: 6.6
Keywords: unimplemented opcode Cc:
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

GHCi 6.6:

This program from the nobench/nofib suite:

http://www.cse.unsw.edu.au/~dons/code/nobench/real/chess

using the input file mygame.pgn, runs to completion on x86/openbsd and amd64/linux.
However on x86/linux (two different machines), it dies with a corrupted bytecode error,
but only with the -w and -v0 flags!

On my test machine I can reproduce this error 1/2 the time:

$ pwd
/home/dons/nobench/real/chess

$ make clean ; runghc -w -v0  chess.hs  < mygames.pgn > /dev/null
rm -f chess Main.hbc  *.actual *.status *~ *.compile *.db
--- GOOD ---

$ make clean ; runghc -w -v0  chess.hs  < mygames.pgn > /dev/null
rm -f chess Main.hbc  *.actual *.status *~ *.compile *.db
chess.hs: internal error: interpretBCO: unknown or unimplemented opcode 55076
    (GHC version 6.6 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
-- FAIL ---

$ make clean ; runghc -w -v0  chess.hs  < mygames.pgn > /dev/null
rm -f chess Main.hbc  *.actual *.status *~ *.compile *.db
--- GOOD --- 

$ make clean ; runghc -w -v0  chess.hs  < mygames.pgn > /dev/null
rm -f chess Main.hbc  *.actual *.status *~ *.compile *.db
chess.hs: internal error: interpretBCO: unknown or unimplemented opcode 55076
    (GHC version 6.6 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
-- FAIL ---

On a bigger machine I was able to reproduce it, though only 1/4 times:

$ make clean ; runghc -w -v0  chess.hs  < mygames.pgn > /dev/null
rm -f chess Main.hbc  *.actual *.status *~ *.compile *.db
chess.hs: internal error: interpretBCO: unknown or unimplemented opcode 34596
    (GHC version 6.6 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (1)

comment:1 Changed 7 years ago by simonmar

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1013

Note: See TracTickets for help on using tickets.