Opened 10 years ago

Closed 4 years ago

#1167 closed bug (wontfix)

mangler makes global symbol disappear on linux-ppc

Reported by: arekm@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.6
Keywords: Cc:
Operating System: Linux Architecture: powerpc
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

Enviroment: linux-ppc, very fresh software, upcoming gcc 4.2, ghc 6.6. I was trying to build alex software which ended with:

GNU ld version 2.17.50.0.12 20070128
  Supported emulations:
   elf32ppclinux
   elf32ppc
   elf32ppcsim
ghc3729_0.hc:(.text+0x104a): undefined reference to `ParseMonad_alexStartPos_closure'
ghc3729_0.hc:(.text+0x104e): undefined reference to `ParseMonad_alexStartPos_closure'
dist/build/alex/alex-tmp/Info.o: In function `shII_info':
ghc3729_0.hc:(.text+0x106e): undefined reference to `Util_lvl1_closure'
ghc3729_0.hc:(.text+0x1072): undefined reference to `Util_lvl1_closure'
ghc3729_0.hc:(.text+0x107a): undefined reference to `Util_lvl1_closure'
dist/build/alex/alex-tmp/Info.o:(.rodata+0x40): undefined reference to `Util_lvl1_closure'

The problem is that these symbol disappear after going through mangler (so problem is visible only when -O2 is used)

In short the problem is that:

.globl ParseMonad_alexStartPos_closure

disappears.

Attachments (2)

ParseMonad.raw_s (106.2 KB) - added by arekm@… 10 years ago.
problematic file nr 1
ParseMonad.s (90.2 KB) - added by arekm@… 10 years ago.
problematic file nr 2

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by arekm@…

Attachment: ParseMonad.raw_s added

problematic file nr 1

Changed 10 years ago by arekm@…

Attachment: ParseMonad.s added

problematic file nr 2

comment:1 Changed 10 years ago by igloo

Description: modified (diff)
Milestone: 6.6.1

I'm putting this in the 6.6.1 milestone for now as it looks pretty bad if it bites often, but I'm not sure if anyone's actively working on the registerised Linux/PPC port, so we might well end up punting on it.

comment:2 Changed 10 years ago by igloo

Milestone: 6.6.1_|_

No-one seems to be working on maintaining the registerised Linux/PPC port at the moment, so milestoning this as _|_.

comment:3 Changed 4 years ago by morabbin

Type of failure: None/Unknown

Has anyone taken up the reg'd Linux/PPC port? If not, close as won't fix.

comment:4 Changed 4 years ago by simonmar

Resolution: wontfix
Status: newclosed

The mangler is dead.

Note: See TracTickets for help on using tickets.