Opened 7 years ago

Closed 7 years ago

#1139 closed bug (worksforme)

Error when running ghci in emacs buffer

Reported by: guest Owned by:
Priority: normal Milestone:
Component: GHCi Version: 6.6
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

I'm running ghci inside of an emacs buffer. I was trying to load the Control.Monad.Identity module into ghci and encountered this.

Prelude> :add Control.Monad.Identity

<no location info>:
    module `Control.Monad.Identity' is a package module
Failed, modules loaded: none.
Prelude> import Control.Monad.Identity
<interactive>:1:0: parse error on input `import'
Prelude> :show modules
: panic! (the 'impossible' happened)
  (GHC version 6.6 for i386-unknown-mingw32):
	missing linkable

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (2)

comment:1 Changed 7 years ago by igloo

  • Description modified (diff)

comment:2 Changed 7 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce this problem. If anyone knows of a way to then please reopen.

FWIW, :m + Control.Monad.Identity is the way to load modules from packages.

Note: See TracTickets for help on using tickets.