Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1135 closed bug (fixed)

HsTime.h isn't installed by the Windows installer

Reported by: igloo Owned by:
Priority: normal Milestone: Not GHC
Component: libraries (other) Version: 6.6
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

[I'm not sure if this is really a bug in the Windows installer maker or if it's a problem with building the library with ghc (rather than as a standalone cabal package). I can reproduce it on my Windows install, but not with the Debian packages]

Alistair Bayley reports in http://www.haskell.org/pipermail/libraries/2007-February/006864.html

If I try to compile this Main.hs:

module Main where
import Data.Time
main = getCurrentTime >>= print

with this ghc-6.6 command:

ghc --make Main -o test -O

... I get this error:

C:\DOCUME~1\bayleya\LOCALS~1\Temp\ghc728_0\ghc728_0.hc:8:20: HsTime.h:
No such file or directory

Change History (5)

comment:1 Changed 7 years ago by igloo

  • Description modified (diff)

comment:2 Changed 7 years ago by bos

This problem also affects Linux; it's not Windows-specific. But it's not enough to install HsTime?.h; you also have to install HsTimeConfig?.h, because HsTime?.h #includes it. I have no idea where HsTimeConfig?.h comes from; it's not part of the time package, and in fact I can't build the time package standalone because it's nowhere to be found. It seems to be built by configure.ac from include/HsTimeConfig.h.in, but that doesn't show up in my darcs repo. Help!

comment:3 Changed 7 years ago by ross

  • Milestone changed from 6.6.1 to Not GHC
  • Resolution set to fixed
  • Status changed from new to closed

Fixed for GHC build by patch HsTime.h should be installed.
Fixed for Cabal build by patch includes -> install-includes.
README now mentions autoreconf for Cabal build from darcs.

comment:4 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:5 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.