Opened 7 years ago

Closed 7 years ago

#1130 closed bug (worksforme)

GHC reports : <interactive>: internal error: removeFromQueues

Reported by: michal <Dot> doborogost (@… Owned by: simonmar
Priority: normal Milestone: 6.6.1
Component: Runtime System Version: 6.6
Keywords: Cc: michael.doborogost@…
Operating System: Windows Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

GHCi reports an unusual error that it asks to "please report". Note that we run the same, purely functional code twice and get two different results. The first time in runs correctly the second time GHCi panics.

Session included below, please contact if more information is required:

*Parser> Parser.parse $ Scanner.adaScanner $ Normalizer.normalizer "declare i : Integer; begin null; end;"
Loading package haskell98 ... linking ... done.

Right (Block { ... })


*Parser> Parser.parse $ Scanner.adaScanner $ Normalizer.normalizer "declare i : Integer; begin null; end;"

<interactive>: internal error: removeFromQueues
    (GHC version 6.6 for i386_unknown_mingw32)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Change History (4)

comment:1 Changed 7 years ago by igloo

  • Component changed from Compiler to Runtime System
  • Description modified (diff)
  • Milestone set to 6.6.1

comment:2 Changed 7 years ago by igloo

  • Owner set to simonmar
  • Priority changed from highest to normal

We don't have a testcase for this, and the e-mail address given is bouncing.

Looking at the code, the problem seems to be a missing case in removeFromQueues.
The BlockedOnCCall and BlockedOnCCall_NoUnblockExc cases seem to be the only ones that aren't handled, but I haven't tried to work out if they can occur or not.

Otherwise, if the cause isn't clear, I think we'll have to close it as unreproducible.

comment:3 Changed 7 years ago by simonmar

  • Cc michael.doborogost@… added

I can't see a way that this could happen - as far as I can tell, removeFromQueues is never called on a thread that is BlockedOnCCall or BlockedOnCCall_NoUnblockExc. We can't handle these cases in removeFromQueues: it isn't possible to raise an exception in a thread that is in a foreign call.

So we need to see the repro case. I've taken a guess at the submitter's email address and put it in the CC field.

comment:4 Changed 7 years ago by simonmar

  • Resolution set to worksforme
  • Status changed from new to closed

No response from submitter, closing the bug as unreproducible.

Note: See TracTickets for help on using tickets.