Opened 7 years ago

Closed 7 years ago

#1124 closed bug (duplicate)

Panic! The impossible happened: initC srt

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.7
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Hallo,

while compiling this abbreviated program:

{-# OPTIONS_GHC -farrows -fno-monomorphism-restriction -fglasgow-exts #-}
module Main where
import Control.Arrow

data Pair a b = a :# b

main = undefined

counter = 
  proc x ->
    do t :# _ <- undefined -< x 
       rec (cnt:: Int) <- undefined -< undefined
           undefined -< show cnt
       returnA -< undefined

the following error occurs:

> ghc --make play.hs

[1 of 1] Compiling Main             ( play.hs, play.o )
ghc-6.7: panic! (the 'impossible' happened)
  (GHC version 6.7 for i386-unknown-linux):
        initC: srt

Version infos:

> gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)

> ghc -V
The Glorious Glasgow Haskell Compilation System, version 6.7

GHC was build using the repositories from 10 January 2007.

This error seems to be very sensitive to details, I had a hard time condensing the error to the program above. Using flags like -O, -fvia-C didn't help.

You can reach me for questions and help via e-mail: ghc-bug@…

Cheers,

Harald Holtmann

Change History (1)

comment:1 Changed 7 years ago by simonpj

  • Resolution set to duplicate
  • Status changed from new to closed

Harald,

Thanks for a fine report. It's a duplicate of #1080, which Ross Paterson is working on. I've added your example to #1080, and closing this as a dup.

Simon

Note: See TracTickets for help on using tickets.