Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#1119 closed merge (fixed)

openBinaryFile: does not exist (No such file or directory) i386-unknown-linux

Reported by: guest Owned by: igloo
Priority: normal Milestone: 6.6.1
Component: Compiler Version: 6.6
Keywords: Edison prelude crash Cc: jyasskin@…
Operating System: Unknown/Multiple Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description (last modified by igloo)

I downloaded Edison, and loaded edison-api/src/Data/Edison/Assoc.hs

The directory contains a file called Prelude.hs, which is probably the cause for the compiler's incorrect behaviour.

  / _ \ /\  /\/ __(_)
 / /_\// /_/ / /  | |      GHC Interactive, version 6.6, for Haskell 98.
/ /_\\/ __  / /___| |      http://www.haskell.org/ghc/
\____/\/ /_/\____/|_|      Type :? for help.

Loading package base ... linking ... done.

<interactive>:1:85:
    Bad interface file: Prelude.hi
        Prelude.hi: openBinaryFile: does not exist (No such file or directory)
ghc-6.6: panic! (the 'impossible' happened)
  (GHC version 6.6 for i386-unknown-linux):
        interactiveUI:setBuffering

Change History (8)

comment:1 Changed 9 years ago by igloo

  • Description modified (diff)
  • Milestone set to 6.6.1
  • Priority changed from normal to low

comment:2 Changed 8 years ago by simonmar

  • Owner set to simonmar

comment:3 Changed 8 years ago by simonmar

See also #1206

comment:4 Changed 8 years ago by simonmar

  • Priority changed from low to normal

comment:5 Changed 8 years ago by jyasskin

  • Cc jyasskin@… added

comment:6 Changed 8 years ago by simonmar

  • Owner changed from simonmar to igloo
  • Type changed from bug to merge

Fixed. You'll still have problems if you have a module Prelude.hs in the current directory, because the implicit import Prelude will refer to that instead of base:Prelude, but this seems to be following the spec to me so I'm not inclined to change it. You can now have a System/IO.hs in your program and use it in GHCi without any problems (except that you won't be able to refer to the System.IO in base, of course).

To merge:

Tue Mar 27 08:22:15 PDT 2007  Simon Marlow <[email protected]>
  * partial fix for #1119
Tue Mar 27 08:37:23 PDT 2007  Simon Marlow <[email protected]>
  * more improvements for #1119
Tue Mar 27 08:45:54 PDT 2007  Simon Marlow <[email protected]>
  * make GHCi use base:Prelude, not just Prelude

comment:7 Changed 8 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

Merged.

comment:8 Changed 7 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.