Opened 3 years ago

Closed 3 years ago

#11093 closed bug (worksforme)

T9579 fails on OS X

Reported by: bgamari Owned by:
Priority: normal Milestone: 8.0.1
Component: Test Suite Version: 7.10.2
Keywords: Cc:
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

As pointed out in ticket:9579#comment:19 the testcase T9579 fails on OS X,

Actual stdout output differs from expected:
--- ./T9579_outofheap_rtsall.stdout.normalised	2015-06-16 14:06:15.000000000 -0400
+++ ./T9579_outofheap_rtsall.run.stdout.normalised	2015-06-16 14:06:15.000000000 -0400
@@ -1,4 +1,4 @@
 T9579_outofheap_rtsall: Heap exhausted;
-T9579_outofheap_rtsall: Current maximum heap size is NUM bytes (1 MB).
+T9579_outofheap_rtsall: Current maximum heap size is 1048576 bytes (1 MB).
 T9579_outofheap_rtsall: Use `+RTS -M<size>' to increase it.
 251
\ No newline at end of file
*** unexpected failure for T9579_outofheap_rtsall(normal)

The issue appears to be a difference in sed's behavior on OS X. The number in the error message is supposed to be replaced by NUM with sed -e 's/[0-9]* bytes/NUM bytes/g'. Perhaps someone with access to an OS X box could shed some light on this?

Change History (3)

comment:1 Changed 3 years ago by thomie

Operating System: Unknown/MultipleMacOS X

Maybe a similar change as in 82cf6724b97ed40d5efedfd28bd3cccf90d1dff2 can be performed, where \+ was replaced by \{1,\}.

comment:2 Changed 3 years ago by thomie

Component: CompilerTest Suite

comment:3 Changed 3 years ago by bgamari

Resolution: worksforme
Status: newclosed

Oddly enough I can't reproduce this on our OS X test box.

Note: See TracTickets for help on using tickets.