Opened 2 years ago

Closed 2 years ago

#10888 closed bug (duplicate)

ghci crashes

Reported by: parsifal9 Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.10.2
Keywords: Cc:
Operating System: Linux Architecture: arm
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Hi all, the compiler was installed from the file ghc_7.10.2-2_armhf.deb

localhost: arch armv7l

localhost: ghci
GHCi, version 7.10.2: http://www.haskell.org/ghc/  :? for help
Prelude> :l Course/List.hs
[1 of 2] Compiling Course.Core      ( Course/Core.hs, interpreted )
[2 of 2] Compiling Course.List      ( Course/List.hs, interpreted )
Ok, modules loaded: Course.List, Course.Core.
*Course.List> (1:. 2:. Nil) ++ (1:. 2:. Nil)
[1,2,1,2Segmentation fault (core dumped)

The files Core.hs and List.hs are attached. I dont know how to cut the example down any smaller. Sorry.

Attachments (1)

course2.tgz (1.3 KB) - added by parsifal9 2 years ago.
two files to reproduce the error

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by parsifal9

Attachment: course2.tgz added

two files to reproduce the error

comment:1 Changed 2 years ago by erikd

This is probably a dupe of #10375.

comment:2 Changed 2 years ago by erikd

Resolution: duplicate
Status: newclosed

This is *definitely* a dupe of #10375 which has been fixed in git HEAD and will almost certainly be in any 7.10.3 release.

Closing this.

Note: See TracTickets for help on using tickets.