Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#10849 closed bug (fixed)

Injective type families broke debug build

Reported by: nomeata Owned by: jstolarek
Priority: normal Milestone: 8.0.1
Component: Compiler (Type checker) Version: 7.10.2
Keywords: Cc: simonpj
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: GHC rejects valid program Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Hi,

since changeset:3744578 Travis observes these failures when built with DEBUG on:

Compile failed (status 256) errors were:
ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.11.20150903 for x86_64-unknown-linux):
	ASSERT failed! file compiler/typecheck/TcInteract.hs, line 1381

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug


*** unexpected failure for T5490(normal)

Actual stderr output differs from expected:
--- ./indexed-types/should_fail/T5439.stderr.normalised	2015-09-03 04:54:51.184120403 +0000
+++ ./indexed-types/should_fail/T5439.comp.stderr.normalised	2015-09-03 04:54:51.184120403 +0000
@@ -1,25 +1,5 @@
+ghc: panic! (the 'impossible' happened)
+  (GHC version 7.11.20150903 for x86_64-unknown-linux):
+	ASSERT failed! file compiler/typecheck/TcInteract.hs, line 1381
 
-T5439.hs:82:28:
-    Couldn't match type ‘Attempt (HElemOf rs)’
-                   with ‘Attempt (HHead (HDrop n0 l0)) -> Attempt (HElemOf l0)’
-    Expected type: f (Attempt (HNth n0 l0) -> Attempt (HElemOf l0))
-      Actual type: f (Attempt (WaitOpResult (WaitOps rs)))
-    Relevant bindings include
-      register :: Bool -> Peano n -> WaitOps (HDrop n rs) -> IO Bool
-        (bound at T5439.hs:64:9)
-      ev :: f (Attempt (WaitOpResult (WaitOps rs)))
-        (bound at T5439.hs:61:22)
-      ops :: WaitOps rs (bound at T5439.hs:61:18)
-      registerWaitOp :: WaitOps rs
-                        -> f (Attempt (WaitOpResult (WaitOps rs))) -> IO Bool
-        (bound at T5439.hs:61:3)
-    In the first argument of ‘complete’, namely ‘ev’
-    In the expression: complete ev
-
-T5439.hs:82:39:
-    Couldn't match expected type ‘Peano n0’
-                with actual type ‘Attempt α0’
-    In the second argument of ‘($)’, namely
-      ‘Failure (e :: SomeException)’
-    In the second argument of ‘($)’, namely
-      ‘inj $ Failure (e :: SomeException)’
\ No newline at end of file
+Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
\ No newline at end of file
*** unexpected failure for T5439(normal)

}}}

Change History (3)

comment:1 Changed 2 years ago by jstolarek

Cc: simonpj added

Yes, I am aware of this breakage. Sadly, the cause lies in the solver code written by Simon and I am unable to fix it. I spoke to Simon about this at ICFP and he promised to take a look.

comment:2 Changed 2 years ago by jstolarek

Resolution: fixed
Status: newclosed

comment:3 Changed 22 months ago by thomie

Milestone: 8.0.1
Note: See TracTickets for help on using tickets.