Opened 2 years ago

Closed 2 years ago

#10611 closed bug (worksforme)

Runtime crash while running psc

Reported by: qxjit Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.3
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Got a runtime crash while running the purescript compiler:

psc: internal error: evacuate(static): strange closure type 6647784

(GHC version 7.8.3 for x86_64_unknown_linux)

As yet I have not be able to reproduce it.

Change History (3)

comment:1 Changed 2 years ago by thomie

Status: newinfoneeded

Can you try to reproduce this problem with the latest GHC release? Thanks.

comment:2 Changed 2 years ago by qxjit

That's quite difficult since I wasn't able to reproduce it originally. Feel free to close the ticket if nothing can be done without more info. Sorry for taking up your time!

comment:3 in reply to:  2 Changed 2 years ago by thomie

Resolution: worksforme
Status: infoneededclosed

Replying to qxjit:

That's quite difficult since I wasn't able to reproduce it originally. Feel free to close the ticket if nothing can be done without more info.

Ok, I will. Bugs that resulted in the same error message have been fixed since 7.8.3, so I hope this one is fixed as well.

Thanks for reporting, and don't hesitate to report any future issues you might run into.

Note: See TracTickets for help on using tickets.