Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#10416 closed bug (fixed)

GHC 7.10.1 User Guide profiling section 5.4 missing images

Reported by: alanz Owned by:
Priority: normal Milestone: 8.0.1
Component: Documentation Version: 7.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Documentation bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s): Phab:D958, Phab:D970
Wiki Page:

Change History (17)

comment:1 Changed 2 years ago by thoughtpolice

This was apparently changed (on purpose) by b30c6012c7552c874281050d40e5a59012b2c5e7, but I'm not sure why. I'll try to fix.

comment:2 Changed 2 years ago by ezyang

Owner: set to thoughtpolice

comment:3 Changed 2 years ago by thoughtpolice

Differential Rev(s): Phab:D958
Status: newpatch

comment:4 Changed 2 years ago by Austin Seipp <austin@…>

In dcaaa980dc59202744bb3888d9662f9a7558cdf6/ghc:

docs: Fix #10416

Summary:
Apparently this was broken by b30c6012c7552c874281050d40e5a59012b2c5e7,
but I can't reproduce the issue described there at all.

Signed-off-by: Austin Seipp <austin@well-typed.com>

Test Plan: Use my eyes to read the resulting user manual.

Reviewers: hvr, thomie

Reviewed By: thomie

Subscribers: bgamari, thomie

Differential Revision: https://phabricator.haskell.org/D958

GHC Trac Issues: #10416

comment:5 Changed 2 years ago by thoughtpolice

Status: patchmerge

comment:6 Changed 2 years ago by Austin Seipp <austin@…>

In 7944a68f0a91033f50c5d0c56e923948bba30be1/ghc:

Revert "docs: Fix #10416"

This causes the buildbots and other users to choke when building the
user documentation, but I haven't figured out why.

This reverts commit dcaaa980dc59202744bb3888d9662f9a7558cdf6.

comment:7 Changed 2 years ago by thoughtpolice

Owner: thoughtpolice deleted
Status: mergenew

comment:8 Changed 2 years ago by thoughtpolice

Differential Rev(s): Phab:D958Phab:D958, Phab:D970
Status: newpatch

comment:9 Changed 2 years ago by Austin Seipp <austin@…>

In ca39b96ee783e124909a89ea3ad366bf99defa7b/ghc:

docs: Fix #10416

This commit fixes #10416 by using an EPS-based file-format for embedding
images in the users guide, as opposed to a png. This is because 'latex'
in some distributions is actually 'pdflatex', which supports reading the
size of PNGs in DVI mode, while traditional latex does not.

Rather than fiddle with the build a whole bunch, it's easy and simple to
just convert the png into a eps file and embed that instead.

But apparently we already had an EPS file, added in
1cce2f51656cfbd8c7933a914a4bd981792aa1e6! But it was quite large, so
instead I used `convert` to shrink it down from 1.7MB to about 20kb, the
same size as the original PDF (by using level3 postscript, which is not
as wasteful.)

Signed-off-by: Austin Seipp <austin@well-typed.com>

Differential Revision: https://phabricator.haskell.org/D970

GHC Trac Issues: #10416

comment:10 Changed 2 years ago by thoughtpolice

Status: patchmerge

Should be fixed for good this time!

comment:11 Changed 2 years ago by thoughtpolice

Resolution: fixed
Status: mergeclosed

Merged to ghc-7.10.

comment:13 Changed 2 years ago by thomie

Resolution: fixed
Status: closednew

comment:14 Changed 2 years ago by bgamari

Milestone: 7.10.27.10.3

I think we may need to punt on this for 7.10.2. I spent several hours on this today and have been entirely unable to get even the an <img> tag to be produced in the HTML, much less a rendered image. Sadly DocBook appears to be an antiquated disaster.

comment:15 Changed 2 years ago by thomie

Type of failure: None/UnknownDocumentation bug

comment:16 Changed 2 years ago by bgamari

Resolution: fixed
Status: newclosed

This is fixed in the ReST-ified user guide

comment:17 Changed 2 years ago by bgamari

Milestone: 7.10.38.0.1

Not fixed in 7.10.3, only in 8.0.

Note: See TracTickets for help on using tickets.