Opened 3 years ago

Closed 3 years ago

#10389 closed bug (duplicate)

ghc: panic! (the 'impossible' happened) when building "bitmap-0.0.2"

Reported by: yairchu Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.10.1
Keywords: Cc:
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Output from "cabal install bitmap":

Resolving dependencies...
Configuring bitmap-0.0.2...
Building bitmap-0.0.2...
Failed to install bitmap-0.0.2
Build log ( /Users/yairchu/.cabal/logs/bitmap-0.0.2.log ):
Configuring bitmap-0.0.2...
Building bitmap-0.0.2...
Preprocessing library bitmap-0.0.2...
[ 1 of 10] Compiling Data.Bitmap.Internal ( Data/Bitmap/Internal.hs, dist/build/Data/Bitmap/Internal.o )
[ 2 of 10] Compiling Data.Bitmap.Base ( Data/Bitmap/Base.hs, dist/build/Data/Bitmap/Base.o )
[ 3 of 10] Compiling Data.Bitmap.IO   ( Data/Bitmap/IO.hs, dist/build/Data/Bitmap/IO.o )

Data/Bitmap/IO.hs:1248:1: Warning:
    SPECIALISE pragma for non-overloaded function ‘myPlusPtr’

Data/Bitmap/IO.hs:1249:1: Warning:
    SPECIALISE pragma for non-overloaded function ‘myPlusPtr’
ghc: panic! (the 'impossible' happened)
  (GHC version 7.10.1 for x86_64-apple-darwin):
	Template variable unbound in rewrite rule
  $fPixelComponentFloat3_X2Rc
  [$fPixelComponentFloat3_X2Rc]
  [$fPixelComponentFloat3_X2Rc]
  []
  []

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

cabal: Error: some packages failed to install:
bitmap-0.0.2 failed during the building phase. The exception was:
ExitFailure 1

Reporting this here as suggested by the error message..

Change History (1)

comment:1 Changed 3 years ago by simonpj

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #10251, which is fixed in 7.10.2. So I'll close as a duplicate; re-open if I'm wrong.

Simon

Note: See TracTickets for help on using tickets.