Opened 3 years ago

Closed 2 years ago

#10386 closed bug (fixed)

Documentation for -Wall is wrong

Reported by: AlexET Owned by: AlexET
Priority: normal Milestone: 7.10.2
Component: Documentation Version: 7.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Documentation bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s): Phab:D889
Wiki Page:

Description

The documentation talks about the flags not enabled by -Wall and then lists the flags enabled by -Wall.

Either the negative should be removed or the flags changed to be the ones not implied by -Wall.

Change History (6)

comment:1 Changed 3 years ago by AlexET

Owner: set to AlexET

comment:2 Changed 3 years ago by thomie

Differential Rev(s): Phab:D889
Status: newpatch

comment:3 Changed 3 years ago by Austin Seipp <austin@…>

In 5cbac8866e1cf1f5a015e318bf298954b7bf6417/ghc:

user guide: correct documentation for -Wall (fixes #10386)

This fixes the documentation for -Wall.
As was done previously it leaves out deprecated flags and also
fwarn-safe and fwarn-unsafe. I don't know
if that was intended or not. -fwarn-safe and fwarn-unsafe are
not mentioned on the warnings page at all instead they are
mentioned in the safe haskell section.

Reviewed By: austin

Differential Revision: https://phabricator.haskell.org/D889

GHC Trac Issues: #10386

comment:4 Changed 2 years ago by ezyang

Resolution: fixed
Status: patchclosed

comment:5 Changed 2 years ago by ezyang

Milestone: 7.10.2
Status: closedmerge

comment:6 Changed 2 years ago by thoughtpolice

Status: mergeclosed
Note: See TracTickets for help on using tickets.