Opened 3 years ago

Closed 3 years ago

#10304 closed task (fixed)

Bump Cabal submodule

Reported by: luite Owned by: hvr
Priority: high Milestone: 7.10.2
Component: Compiler Version: 7.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Unfortunately 7.10.1 was released with a Cabal library that has a major bug handling ghcjs-pkg version numbering, introduced after 7.10rc1.

Ryan is away for a few more days, but the current 1.22 HEAD should be essentially the same as the 1.22.3.0 release (other than changelog updates). Can the module be bumped to HEAD now so we can start using the fixed Cabal?

Change History (5)

comment:1 Changed 3 years ago by hvr

Owner: set to hvr

comment:2 Changed 3 years ago by Herbert Valerio Riedel <hvr@…>

In 4bc925a67285a71ddd14642e218d85de83bc214a/ghc:

Update Cabal submodule to 1.22.3.0 release

Highlights since 1.22.2.0:

- cabal check will fail on -fprof-auto passed as a ghc-option
- filterConfigureFlags: filter more flags.
- fix ghcjs-pkg version number handling

Addresses #10304

comment:3 Changed 3 years ago by hvr

Status: newmerge

comment:4 Changed 3 years ago by hvr

Priority: normalhigh

comment:5 Changed 3 years ago by hvr

Resolution: fixed
Status: mergeclosed
Note: See TracTickets for help on using tickets.