Opened 3 years ago

Closed 3 years ago

#10302 closed bug (fixed)

7.10.1 documenation is incorrect wrt supported llvm version

Reported by: George Owned by: thoughtpolice
Priority: high Milestone: 7.10.2
Component: Documentation Version: 7.10.1
Keywords: llvm Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by erikd)

As documented in #9929 ghc 7.10.1 only supports llvm 3.5.

This should be documented in the release notes section of the GHC Users's Guide, Version 7.10.1.

In addition, the following in the Known bugs section needs to be changed to mention this also:

GHC’s LLVM backend is currently incompatible with LLVM 3.4 (issue #9929).

The following in section 4.11.2 should also be changed from:

Currently LLVM 2.8 and later are supported.

to

Only LLVM 3.5 is supported.

from

Secondly, if you are running Mac OS X with LLVM 3.0 or greater

to

Secondly, if you are running Mac OS X with LLVM 3.5

from

In order to use the LLVM based code generator, you should install the Homebrew package manager for OS X.

to

In order to use the LLVM based code generator, you should install the Homebrew package manager for OS X and then install LLVM 3.5

Change History (5)

comment:1 Changed 3 years ago by George

Priority: normalhigh

comment:2 Changed 3 years ago by George

Summary: 7.10.1 documenation is incorrect wrt llvm7.10.1 documenation is incorrect wrt supported llvm version

comment:3 Changed 3 years ago by thoughtpolice

Owner: set to thoughtpolice

comment:4 Changed 3 years ago by erikd

Description: modified (diff)

comment:5 Changed 3 years ago by thoughtpolice

Resolution: fixed
Status: newclosed

Fixed by 1915e7f3ab4b801bec5557709a18368c20b0036d. This is only in ghc-7.10 because this will all need to change for GHC 7.12 if ImprovedLLVMBackend fully goes through.

Note: See TracTickets for help on using tickets.