Opened 3 years ago

Closed 3 years ago

#10264 closed bug (duplicate)

AArch64 : Installing 7.10.1 fails

Reported by: erikd Owned by:
Priority: normal Milestone: 7.10.2
Component: Compiler Version: 7.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Installing GHC failed Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Built 7.10.1 from the release tarball, using ghc-7.6.3 from Debian. Build of the compiler goes fine, but when I install it I get:

"inplace/bin/ghc-cabal" register libraries/ghc-prim dist-install \
    "/home/erikd/GHC/7.10.1/lib/ghc-7.10.1/bin/ghc" \
    "/home/erikd/GHC/7.10.1/lib/ghc-7.10.1/bin/ghc-pkg" \
    "/home/erikd/GHC/7.10.1/lib/ghc-7.10.1" '' '/home/erikd/GHC/7.10.1' \
    '/home/erikd/GHC/7.10.1/lib/ghc-7.10.1' \
    '/home/erikd/GHC/7.10.1/share/doc/ghc/html/libraries' NO  
Warning: cannot determine version of
/home/erikd/GHC/7.10.1/lib/ghc-7.10.1/bin/ghc-pkg :
""
ghc-cabal: libraries/Cabal/Cabal/Distribution/Simple/GHC.hs:1050:5-47: 
    Irrefutable pattern failed for pattern Data.Maybe.Just ver

The code in question is:

hcPkgInfo :: ProgramConfiguration -> HcPkg.HcPkgInfo
hcPkgInfo conf = HcPkg.HcPkgInfo { HcPkg.hcPkgProgram    = ghcPkgProg
                                 , HcPkg.noPkgDbStack    = v < [6,9]
                                 , HcPkg.noVerboseFlag   = v < [6,11]
                                 , HcPkg.flagPackageConf = v < [7,5]
                                 , HcPkg.useSingleFileDb = v < [7,9]
                                 }
  where
    v               = versionBranch ver
    Just ghcPkgProg = lookupProgram ghcPkgProgram conf
    Just ver        = programVersion ghcPkgProg

Change History (3)

comment:1 Changed 3 years ago by erikd

Milestone: 7.10.2
Type of failure: None/UnknownInstalling GHC failed

comment:2 Changed 3 years ago by erikd

This part looks ok!

/home/erikd/GHC/7.10.1/lib/ghc-7.10.1/bin/ghc-pkg --version
GHC package manager version 7.10.1

Walking through the code Distribution.Simple.Program.Builtin.ghcPkgProgram just calls Distribution.Simple.Utils.findProgramVersion which calls Distribution.Text.simpleParse.

About to test whether the call to rawSystemStdout in findProgramVersion might be throwing an error.

Last edited 3 years ago by erikd (previous) (diff)

comment:3 Changed 3 years ago by erikd

Resolution: duplicate
Status: newclosed

This is a duplicate of #9673.

Note: See TracTickets for help on using tickets.