Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1025 closed merge (fixed)

-ddump-minimal-imports works wrongly

Reported by: maeder@… Owned by: igloo
Priority: normal Milestone: 6.6.1
Component: Compiler Version: 6.6
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

the option -ddump-minimal-imports may fail with:

    Failed to load interface for `System.Console.Shell.Types':
      it is hidden (in package Shellac-0.5)

Furthermore full recompilation does not take place, maybe because no-recomp was renamed to force-recomp. (Please check also other -ddump options for recompilation checking.)

Attachments (1)

B.hs (70 bytes) - added by maeder@… 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by simonpj

Can you give us a repo case please?

Thanks

Simon

Changed 7 years ago by maeder@…

comment:2 Changed 7 years ago by maeder@…

get and install shellac http://www.eecs.tufts.edu/~rdocki01/projects/shellac-0.5-source.tar.gz.

Compile the attached module:

maeder@turing:~/haskell/examples> ghc --make -no-recomp -ddump-minimal-imports B.hs
[1 of 1] Compiling B                ( B.hs, B.o )

B.hs:1:0:
    Failed to load interface for `System.Console.Shell.Commands':
      it is hidden (in package Shellac-0.5)

The cause is the use of the data constructor File.

Without -fforce-recomp (or -no-recomp) the module is not recompiled if it was successfully compiled before without -ddump-minimal-imports

B.hs

module B where
import System.Console.Shell

a :: File
a = File "bla"

comment:3 Changed 7 years ago by simonpj

  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from bug to merge

Excellent. I was able to reproduce this nicely, thank you. It was a silly bug in the -ddump-minimal-imports code. Thanks for the report and repo case.

I'm not adding a test case because the test is a bit elaborate: build a package and then use it.

MERGE to stable.

Wed Feb 7 10:02:45 GMT 2007 simonpj@…

  • Force recompilation on all -ddump flags

Wed Feb 7 10:00:53 GMT 2007 simonpj@…

  • Force recompilation with -ddump-minimal-imports

Wed Feb 7 09:49:45 GMT 2007 simonpj@…

  • Fix bug in -ddump-minimal imports Trac #1025

comment:4 Changed 7 years ago by simonpj

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 7 years ago by simonpj

  • Owner set to igloo
  • Status changed from reopened to new

comment:6 Changed 7 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

Merged.

comment:7 Changed 6 years ago by simonmar

  • Architecture changed from Multiple to Unknown/Multiple

comment:8 Changed 6 years ago by simonmar

  • Operating System changed from Multiple to Unknown/Multiple
Note: See TracTickets for help on using tickets.