Opened 3 years ago

Closed 3 years ago

#10206 closed bug (fixed)

Incorrect links are generated for modules in the index of "Haskell Hiearchical Libraries"

Reported by: pgj Owned by: thoughtpolice
Priority: highest Milestone: 7.10.2
Component: Documentation Version: 7.10.1-rc1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Documentation bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

This was originally spotted and posted to the ghc-devs mailing list by Joachmin Breitner, but apparently since nobody has submitted a ticket for this relatively serious issue, here it is. I am quoting Joachim:

while the index at
http://haskell.inf.elte.hu/docs/7.11.20150222.noWin32/html/libraries/index.html
exists, navigating to
http://haskell.inf.elte.hu/docs/7.11.20150222.noWin32/html/libraries/Data-Char.html
yields a 404 error.

Same for
http://haskell.inf.elte.hu/docs/latest/html/libraries/Data-Char.html

And I have replied the following to his initial email (I am involved in this because I am doing daily snapshots of the documentation through my FreeBSD GHC builders):

Yes, I can confirm this bug.  For what it is worth, the files are all
there, the link appears to be broken: it is missing the subdirectory
with the name of the package.  That is, the proper link should be
something like that:

http://haskell.inf.elte.hu/docs/7.9.20141222.noWin32/html/libraries/base-4.8.0.0/Data-Char.html

(Note the missing "base-4.8.0.0".)  I have checked this with GHC
7.8.3, and everything is right there, while this problem seems to
appear with GHC 7.10 RC2 and GHC-HEAD (starting from somewhere between
mid-September and November -- that is what a quick bisecting tells
me).

Change History (5)

comment:1 Changed 3 years ago by carter

I'm seeing the same problem with userland haddocks wrt the haddock index.html file :(

glad to see this is on the plate for 7.10.2

comment:2 Changed 3 years ago by thoughtpolice

Owner: set to thoughtpolice

comment:3 Changed 3 years ago by hvr

Status: newupstream

comment:4 Changed 3 years ago by Austin Seipp <austin@…>

In 2666ba369f8d3e7d187876b7b602d42f2d6db381/ghc:

haddock: update submodule to fix #10206

Signed-off-by: Austin Seipp <austin@well-typed.com>

comment:5 Changed 3 years ago by thoughtpolice

Resolution: fixed
Status: upstreamclosed

OK, upstream fix merged into ghc-head/master on the haddock repository, and merged into master/ghc-7.10 for us. Closing.

Note: See TracTickets for help on using tickets.