Opened 3 years ago

Closed 3 years ago

#10115 closed bug (fixed)

Unable to run cabal haddock --hoogle on GHC 7.10

Reported by: snoyberg Owned by:
Priority: highest Milestone: 7.10.1
Component: Compiler Version: 7.10.1-rc2
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

At Herbert's recommendation, creating an issue based on the following email I sent to ghc-dev:

I'm not really able to follow the details of this, but I wanted to raise to everyone's attention a serious bug with the current GHC 7.10 RC, Cabal 1.22, and/or Haddock. Currently, running cabal haddock --hoogle does not work. There seem to be two different issues open about it:

https://github.com/haskell/haddock/issues/361 https://github.com/haskell/cabal/issues/2297

I really don't understand the issues here, but I'd claim that the severity of this should probably be a blocker for a GHC 7.10 release.

Change History (4)

comment:1 Changed 3 years ago by snoyberg

Milestone: 7.10.1

comment:2 Changed 3 years ago by Herbert Valerio Riedel <hvr@…>

In cbc7103044cff890c9916c8418b2f93cbece9b83/ghc:

Update Haddock submodule

This pulls in a cherry-picked commit adding support for
the new `--package-name` and `--package-version` flags and thus
helps addressing #10115.

comment:3 Changed 3 years ago by Herbert Valerio Riedel <hvr@…>

In 14b78eb7390dcf78c104501f4c24ac013a70a766/ghc:

Update Cabal submodule to latest 1.22.1.2 snapshot

This addresses the Cabal side of #10115 as this pulls in the following two
commits:

> Make sure to pass the package key to ghc
> Haddock: Use --package-{name|version} when available

comment:4 Changed 3 years ago by hvr

Resolution: fixed
Status: newclosed

This was merged into ghc-7.10 via cb51506b02a2ecf7b5e67a8069e61f4e8375ba67

Also, I can't reproduce this with RC3 anymore, so I'm closing this

Note: See TracTickets for help on using tickets.