GHC 8.6.1 released

The GHC team is pleased to announce the availability of GHC 8.6.1, the fourth major release in the GHC 8 series. The source distribution, binary distributions, and documentation for this release are available at downloads.haskell.org.

The 8.6 release fixes over 400 bugs from the 8.4 series and introduces a number of exciting features. These most notably include:

  • A new deriving mechanism, deriving via, providing a convenient way for users to extend Haskell's typeclass deriving mechanism
  • Quantified constraints, allowing forall quantification in constraint contexts
  • An early version of the GHCi :doc command
  • The ghc-heap-view package, allowing introspection into the structure of GHC's heap
  • Valid hole fit hints, helping the user to find terms to fill typed holes in their programs
  • The BlockArguments extension, allowing the $ operator to be omitted in some unambiguous contexts
  • An exciting new plugin mechanism, source plugins, allowing plugins to inspect and modify a wide variety of compiler representations.
  • Improved recompilation checking when plugins are used
  • Significantly better handling of macOS linker command size limits, avoiding linker errors while linking large projects
  • The next phase of the MonadFail proposal, enabling -XMonadFailDesugaring by default

A full list of the changes in this release can be found in the release notes.

Perhaps of equal importance, GHC 8.6 is the second major release made under GHC's accelerated six-month release schedule and the first set of binary distributions built primarily using our new continuous integration scheme. While the final 8.6 release is around three weeks later than initially scheduled due to late-breaking bug reports, we expect that the 8.8 release schedule shouldn't be affected.

cabal-install users should note that GHC 8.6 can only be used with cabal-install 2.4.0.1 or later.

Thanks to everyone who has contributed to developing, documenting, and testing this release!

As always, let us know if you encounter trouble.

  • Posted: 2018-09-22 00:56 (Updated: 2018-10-14 22:19)
  • Author: Ben Gamari
  • Categories: release

Comments

1. hvr -- 2018-09-22 06:24

GHC 8.6.1 only works properly with tooling which uses lib:Cabal version 2.4.0.1 or later.

As such, GHC 8.6.1 works best with `cabal-install 2.4.0.0` or later; please upgrade if you have an older version of cabal-install.


Here are packaged binary distributions of GHC 8.6.1 and Cabal 2.4 (and others) optimised for Debian & Ubuntu


Ubuntu

Ubuntu users can use my GHC ppa (see https://launchpad.net/~hvr/+archive/ubuntu/ghc) to conveniently install binary packages specifically built for the currently non-EOL'ed Ubuntu releases

  • Ubuntu 14.04 LTS (Trusty),
  • Ubuntu 16.04 LTS (Xenial),
  • Ubuntu 18.04 LTS (Bionic)

Installing is simply a matter of

sudo apt-add-repository ppa:hvr/ghc sudo apt update sudo apt install ghc-8.6.1-prof ghc-8.6.1-htmldocs cabal-install-2.4

and add /opt/ghc/bin to your $PATH, and you should be ready to go. Please refer to the [PPA description](https://launchpad.net/~hvr/+archive/ubuntu/ghc) for additional information on how to manage multiple GHC versions installed side-by-side.

Ubuntu on Windows Subsystem for Linux (WSL)

For the benefit of WSL users these packages use build-settings optimized for WSL (see also https://mail.haskell.org/pipermail/haskell-cafe/2018-February/128591.html). The instructions are the same as the ones described above for the standard Ubuntu packages. The following distributions are supported currently:

  • Ubuntu 14.04 LTS (Trusty)
  • Ubuntu 16.04 LTS (Xenial)
  • Ubuntu 18.04 LTS (Bionic)

Debian 9 (Stretch)

The instructions are similar to the ones for Ubuntu, except for how to setup the repository:

Invoke

sudo apt edit-sources

and add the line

deb http://downloads.haskell.org/debian stretch main

and then proceed as for Ubuntu, i.e.

sudo apt update sudo apt install ghc-8.6.1-prof ghc-8.6.1-htmldocs cabal-install-2.4

and add /opt/ghc/bin to your $PATH if desired. The symlinks for the default ghc/cabal executables are controlled like in Ubuntu via [update-alternatives(1)](http://manpages.ubuntu.com/manpages/xenial/man1/update-alternatives.1.html).

For more details, please consult http://downloads.haskell.org/debian/


Windows & macOS

For Windows and macOS please refer to

and

respectively which are expected to offer packages for GHC 8.6.1 and cabal-install 2.4 real soon now.


Managing multiple GHC versions

For general information about how to manage multiple versions of GHC please, see e.g. https://qfpl.io/posts/multiple-ghcs/

2. takenobu -- 2018-09-22 08:04

The alternative links of downloads.haskell.org are followings:

https://downloads.haskell.org/~ghc/8.6.1/

https://www.haskell.org/ghc/download_ghc_8_6_1.html